summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Kotta2015-08-28 15:27:29 -0500
committerJonathan Kotta2015-08-28 15:27:29 -0500
commitbd0463ace27803571142bd3a4da33c1cb92d0723 (patch)
tree7102bb8e453d32e2188acb1e8941abc3d84f1542 /PKGBUILD
downloadaur-bd0463ace27803571142bd3a4da33c1cb92d0723.tar.gz
import from aur3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77af08ca388b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Andras Biro <bbandi86@gmail.com>
+# Contributor: Alex Forencich <alex at alexforencich dot com>
+# Contributor: Corrado Primier <bardo@aur.archlinux.org>
+# Contributor: danst0 <danst0@west.de>
+_pkgnamenoplatform=libc
+_pkgnamenobrand=avr-${_pkgnamenoplatform}
+pkgname=${_pkgnamenobrand}-atmel
+pkgver=1.8.0
+_atmelver=3.4.4
+pkgrel=1
+pkgdesc="The C runtime library for the AVR family of microcontrollers"
+url="http://www.atmel.com/tools/ATMELAVRTOOLCHAINFORLINUX.aspx"
+arch=('x86_64' 'i686')
+license=('BSD' 'custom')
+depends=('avr-gcc-atmel')
+conflicts=("avr-libc")
+provides=("avr-libc=$pkgver")
+options=('!strip' 'staticlibs')
+source=("http://distribute.atmel.no/tools/opensource/Atmel-AVR-GNU-Toolchain/${_atmelver}/${_pkgnamenobrand}-${pkgver}.tar.bz2")
+md5sums=('9afc252d6457957622909af9f197abe8')
+
+_dirname="libc/avr-libc"
+
+build() {
+ #replace headers - it's not necessary, it's replaced in the tarball already
+# cd ${srcdir}/avr/
+# for i in io[0-9a-zA-Z]*.h
+# do
+# cp --verbose --force $i ../${_dirname}/include/avr
+# done
+
+ cd ${srcdir}/${_dirname}
+ ./bootstrap
+ ./configure --host=avr\
+ --prefix="/usr" \
+ --disable-versioned-doc
+ make
+}
+
+package() {
+ cd ${srcdir}/${_dirname}
+ make DESTDIR=${pkgdir} install
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file