summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072023-08-16 22:15:59 +0200
committersL1pKn072023-08-16 22:15:59 +0200
commit2310527225621f737ad3cd91340508bd29269881 (patch)
treeac15d52802a4a4648fe98f00bf3a41adc8c7e74b /PKGBUILD
parent85c063a6ba1bde4d5073def52b89a4a3761d4595 (diff)
downloadaur-2310527225621f737ad3cd91340508bd29269881.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD102
1 files changed, 56 insertions, 46 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e735ccde65b..3ca95c2ee635 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,52 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgbase=avxsynth-git
-pkgname=('avxsynth-git'
- 'avxedit-git'
- )
+pkgname=(
+ 'avxsynth-git'
+ 'avxedit-git'
+)
pkgver=20150407.80dcb7e
-pkgrel=5
+pkgrel=6
pkgdesc="Linux Port of AviSynth. (Git version)"
arch=('x86_64')
url='http://www.avxsynth.org'
license=('GPL2')
-makedepends=('git'
- 'yasm'
- 'python'
- 'qt5-base'
- 'qt5-tools'
-# 'mplayer'
- 'log4cpp'
- 'pango'
- 'libjpeg-turbo'
- 'sdl12-compat'
- )
-source=('git+https://github.com/avxsynth/avxsynth.git'
- 'https://ffmpeg.org/releases/ffmpeg-4.4.3.tar.bz2'
- 'https://github.com/FFMS/ffms2/archive/refs/tags/2.23.tar.gz'
- 'https://patch-diff.githubusercontent.com/raw/avxsynth/avxsynth/pull/120.diff'
- 'https://patch-diff.githubusercontent.com/raw/avxsynth/avxsynth/pull/121.diff'
- 'https://patch-diff.githubusercontent.com/raw/avxsynth/avxsynth/pull/122.diff'
- 'https://patch-diff.githubusercontent.com/raw/avxsynth/avxsynth/pull/126.diff'
- 'c++11_fix.patch'
- 'qt5.patch'
- )
-sha256sums=('SKIP'
- '33b8c2dbcd530fe1db5710415345609b4ca227bd0da1e3a9332dbb0f11fd273a'
- 'b09b2aa2b1c6f87f94a0a0dd8284b3c791cbe77f0f3df57af99ddebcd15273ed'
- '87952a30be26f6db89e5b1d89c9bdb9c9567654bdaa2ce80503ce28f8f0a272a'
- '6534ae6c2e09b3c13ca4d9c47e1d3a4c8895575d3202b0d3ab80b25504bff94d'
- 'a2cf0517db8368c53912cde5cbd81d6f29cf0c4a5db5a25483284fe0b38012cb'
- 'f6a825b6b5da58d7ebdb67252885262908bda86edf248b78771c8ffaef3e00b9'
- 'ac83efa3a3a78ed4c1935ea47dafbdb46b9c6b03c1f4ab214850eda708ee0cc6'
- 'fb155fc2dbdb2450c3761781c571ec4335d1fa5169bd1fb2332386eb047c6d8a'
- )
+makedepends=(
+ 'git'
+ 'yasm'
+ 'python'
+ 'qt5-base'
+ 'qt5-tools'
+# 'mplayer'
+ 'log4cpp'
+ 'pango'
+ 'libjpeg-turbo'
+ 'sdl12-compat'
+)
+source=(
+ 'git+https://github.com/avxsynth/avxsynth.git'
+ 'https://ffmpeg.org/releases/ffmpeg-4.4.4.tar.bz2'
+ 'https://github.com/FFMS/ffms2/archive/refs/tags/2.23.tar.gz'
+ 'https://patch-diff.githubusercontent.com/raw/avxsynth/avxsynth/pull/120.diff'
+ 'https://patch-diff.githubusercontent.com/raw/avxsynth/avxsynth/pull/121.diff'
+ 'https://patch-diff.githubusercontent.com/raw/avxsynth/avxsynth/pull/122.diff'
+ 'https://patch-diff.githubusercontent.com/raw/avxsynth/avxsynth/pull/126.diff'
+ 'c++11_fix.patch'
+ 'qt5.patch'
+ 'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb'
+)
+sha256sums=(
+ 'SKIP'
+ '47b1fbf70a2c090d9c0fae5910da11c6406ca92408bb69d8c935cd46c622c7ce'
+ 'b09b2aa2b1c6f87f94a0a0dd8284b3c791cbe77f0f3df57af99ddebcd15273ed'
+ '87952a30be26f6db89e5b1d89c9bdb9c9567654bdaa2ce80503ce28f8f0a272a'
+ '6534ae6c2e09b3c13ca4d9c47e1d3a4c8895575d3202b0d3ab80b25504bff94d'
+ 'a2cf0517db8368c53912cde5cbd81d6f29cf0c4a5db5a25483284fe0b38012cb'
+ 'f6a825b6b5da58d7ebdb67252885262908bda86edf248b78771c8ffaef3e00b9'
+ 'ac83efa3a3a78ed4c1935ea47dafbdb46b9c6b03c1f4ab214850eda708ee0cc6'
+ 'fb155fc2dbdb2450c3761781c571ec4335d1fa5169bd1fb2332386eb047c6d8a'
+ 'fec03e133521486ca258ae34ddf093eb6aab23f848c4332c367aadbfeaefda04'
+)
pkgver() {
cd avxsynth
@@ -64,6 +70,10 @@ prepare() {
# Build on Qt5
patch -p1 -i "${srcdir}/qt5.patch"
+ cd ../ffmpeg-4.4.4
+ # Build with binutils +2.41
+ patch -p1 -i "${srcdir}/effadce6c756247ea8bae32dc13bb3e6f464f0eb"
+
}
build() {
@@ -72,7 +82,7 @@ build() {
export PYTHON=python
cd "${srcdir}/build-ffmpeg"
- ../ffmpeg-4.4.3/configure \
+ ../ffmpeg-4.4.4/configure \
--prefix="${srcdir}/fakeroot" \
--disable-{network,{encod,mux}ers,hwaccels,{in,out}devs,debug,programs,doc,vdpau,vaapi,cuda,cuvid,nvenc} \
--enable-pic \
@@ -108,13 +118,12 @@ build() {
package_avxsynth-git() {
pkgdesc="Linux Port of AviSynth. (Git version)"
- depends=('log4cpp'
- 'libpango-1.0.so'
- 'libpangocairo-1.0.so'
- 'libpangoft2-1.0.so'
- 'sdl12-compat'
- 'libjpeg.so'
- )
+ depends=(
+ 'log4cpp'
+ 'pango' 'libpango-1.0.so' 'libpangocairo-1.0.so' 'libpangoft2-1.0.so'
+ 'sdl12-compat'
+ 'lib32-libjpeg-turbo' 'libjpeg.so'
+ )
provides=('avxsynth')
conflicts=('avxsynth')
@@ -124,9 +133,10 @@ package_avxsynth-git() {
package_avxedit-git() {
pkgdesc="Simple Qt frontend for create/edit/test AvxSynth scripts. (Git version)"
- depends=('qt5-base'
- 'avxsynth-git'
- )
+ depends=(
+ 'qt5-base'
+ 'avxsynth-git'
+ )
provides=('avxedit')
conflicts=('avxedit')