summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072024-02-25 12:22:53 +0100
committersL1pKn072024-02-25 12:22:53 +0100
commit3fe94584ed28db6640d7b69937645ee8efbfc0fa (patch)
treec2907bd00ef1ea5261419df346ff26e038250db5 /PKGBUILD
parent878b46a084f580fdbf07580ac4927e579a1c3b25 (diff)
downloadaur-avxsynth-plugin-decomb.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4d0ce352ada..96270963c598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,30 @@
_plug=decomb
pkgname=avxsynth-plugin-decomb
pkgver=5.2.3
-pkgrel=3
+pkgrel=4
pkgdesc="Plugin for Avxsynth: ${_plug}"
arch=('x86_64')
url='https://web.archive.org/web/20130724044827/http://mujintou.org.uk/avxsynth'
license=('GPL')
depends=('avxsynth-git')
-makedepends=('git'
- 'yasm'
- 'cmake'
- )
+makedepends=(
+ 'git'
+ 'yasm'
+ 'cmake'
+)
source=("https://web.archive.org/web/20150801145006if_/http://mujintou.org.uk/projects/decomb.zip")
sha256sums=('3c8efb8ea8c831c67c9af8ce9ccc7a0c18416ac75b1374181ced0708a68c36ba')
provides=("avxsynth-plugin-${_plug}")
conflicts=("avxsynth-plugin-${_plug}")
-prepare() {
- mkdir -p build
-}
-
build() {
- cd build
- cmake ../decomb \
+ CXXFLAGS+=' -Wno-format-security'
+
+ cmake -S decomb -B build \
-DCMAKE_INSTALL_PREFIX=/usr/lib/avxsynth \
-DCMAKE_ASM_NASM_COMPILER=yasm
- make
+ cmake --build build
}
package(){