summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 15:52:25 +0200
committersl1pkn072015-06-08 15:52:25 +0200
commitaeb36fa38bbffe65e6ad19da65b72097765b09f0 (patch)
treedba584262d9b2cfeb5955d958ddf1af5f360e33a /PKGBUILD
downloadaur-aeb36fa38bbffe65e6ad19da65b72097765b09f0.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..009d9d77363a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=depan
+pkgname=avxsynth-plugin-${_plug}-git
+pkgver=1.11.0.1.ga5f2b95
+pkgrel=1
+pkgdesc="Plugin for Avxsynth. ${_plug} (GIT)"
+arch=('i686' 'x86_64')
+url="https://github.com/btb/depan"
+license=('GPL')
+depends=('avxsynth' 'fftw')
+makedepends=('git' 'cmake')
+provides=("avxsynth-plugin-${_plug}")
+conflicts=("avxsynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/btb/depan.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | sed 's|depan-||g' | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake "../${_plug}" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package(){
+ make -C build DESTDIR="${pkgdir}" install
+}
+