summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2019-08-26 08:58:52 +0300
committerCaleb Maclennan2019-08-26 09:32:14 +0300
commite4844e7d2519c2ab395182511f1ae80ddb9eff11 (patch)
tree2e9bb68531fe301b77cee60e94330f3cf96cb4a5 /PKGBUILD
parenta4cf25704576f769ea5fef3b42c37cf5d917bd9a (diff)
downloadaur-e4844e7d2519c2ab395182511f1ae80ddb9eff11.tar.gz
Switch to way-cool fork
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55c88779907f..2ff7eaf09506 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: Oleg Shparber <trollixx+aur@gmail.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Oleg Shparber <trollixx+aur@gmail.com>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Sébastien Luttringer
# Contributor: xduugu
# Contributor: Ronald van Haren <ronald.archlinux.org>
# Contributor: Vesa Kaihlavirta
-# URL: https://github.com/trollixx/aur-packages
# Upstream: https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/awesome
-_pkgname=awesome
+_pkgbase=awesome
+_pkgname=${_pkgbase}-way-cooler
pkgname=${_pkgname}-git
-pkgver=4.3.318.g6101ef51
+pkgver=4.3.r333.g3b4f3640
pkgrel=1
-pkgdesc='Highly configurable framework window manager'
+pkgdesc='Highly configurable framework window manager (wayland compatible fork using way-cooler)'
arch=('i686' 'x86_64')
-url='http://awesome.naquadah.org/'
+url='https://github.com/way-cooler/awesome'
license=('GPL2')
depends=('cairo' 'dbus' 'gdk-pixbuf2' 'libxdg-basedir' 'libxkbcommon-x11'
'lua' 'lua-lgi' 'pango' 'startup-notification' 'xcb-util-cursor'
- 'xcb-util-keysyms' 'xcb-util-wm' 'xcb-util-xrm' 'libxfixes')
+ 'xcb-util-keysyms' 'xcb-util-wm' 'xcb-util-xrm' 'libxfixes' 'way-cooler')
makedepends=('asciidoc' 'cmake' 'docbook-xsl' 'git' 'imagemagick' 'ldoc'
'xmlto')
optdepends=('rlwrap: readline support for awesome-client'
@@ -26,15 +27,15 @@ optdepends=('rlwrap: readline support for awesome-client'
'xcb-util-errors: for pretty-printing of X11 errors'
'librsvg: for displaying SVG files without scaling artifacts'
)
-provides=('notification-daemon' 'awesome')
-conflicts=('awesome')
-backup=('etc/xdg/awesome/rc.lua')
-source=("$pkgname::git+https://github.com/awesomeWM/awesome.git")
-md5sums=('SKIP')
+provides=('notification-daemon' "$_pkgbase")
+conflicts=("$_pkgbase")
+backup=("etc/xdg/$_pkgbase/rc.lua")
+source=("$pkgname::git+https://github.com/way-cooler/$_pkgbase.git")
+sha256sums=('SKIP')
pkgver() {
cd $pkgname
- git describe | sed 's/^v//;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {