summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam Therapy2022-11-07 15:44:10 +0100
committerSam Therapy2022-11-07 15:44:10 +0100
commitc58ad5346a6f820d8a7e7ed7b1d187c5b4f76468 (patch)
tree5d136b61a2bc07d31a9035ee1e2cb6c479a65534 /PKGBUILD
parenta38be687ff081beaf23c0562e1448e7ab8c14f2f (diff)
downloadaur-c58ad5346a6f820d8a7e7ed7b1d187c5b4f76468.tar.gz
fix: make version actually show up
It didn't before, and for some reason rearranging the GOFLAGS consistently works.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f60e4f8fef1d..be9993535025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sam Therapy <sam at samtherapy dot net>
pkgname=awl-dns-git
-pkgver=0.5.2.r32.g2d94ea6
+pkgver=0.5.8.r10.ga64a260
pkgrel=1
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
pkgdesc="A DNS client"
@@ -8,7 +8,7 @@ url="https://git.froth.zone/sam/awl"
license=('BSD')
makedepends=(
'git'
- 'go>=1.18'
+# 'go>=1.18'
'scdoc'
)
provides=("${pkgname%-*}")
@@ -28,7 +28,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -ldflags=-X=main.version=${pkgver} -ldflags=-s -ldflags=-w -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-s -ldflags=-w -ldflags=-linkmode=external -ldflags=-X=main.version=${pkgver} -mod=readonly -modcacherw"
export CGO_ENABLED=1
make VERSION=$pkgver DESTDIR="$pkgdir" PREFIX="/usr"