summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2020-04-09 10:41:58 +0300
committerChristoph Gysin2020-04-09 10:41:58 +0300
commit96388e3490885c0ebd5b9c2ad19a0d6d8f3fd333 (patch)
treed3250aa478d2e826b75feebc7886aff1129722da /PKGBUILD
downloadaur-96388e3490885c0ebd5b9c2ad19a0d6d8f3fd333.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2732f51e7fc0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+
+pkgname=aws-cfn-template-flip
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Tool for converting AWS CloudFormation templates between JSON and YAML formats."
+url="https://github.com/awslabs/aws-cfn-template-flip"
+license=('BSD')
+
+source=("$url/archive/${pkgver}.tar.gz")
+sha256sums=('c2780f27b74bd14222d19dd82b2b60ca6451c91e5a5ea963758b085bf9dde9ea')
+depends=('python-click' 'python-yaml')
+makedepends=('python-distribute')
+arch=('any')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}