summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSteve Engledow2020-09-01 12:01:24 +0100
committerSteve Engledow2020-09-01 12:01:24 +0100
commitf86a9699e9fbf81ac6aee2a09664f6b5c1ff07f1 (patch)
tree33a3673984ccac21c02339debdfb17004e8ffa7b /PKGBUILD
parent8d6601becc25be7edb3373acc7a2de79c1b68e2a (diff)
downloadaur-f86a9699e9fbf81ac6aee2a09664f6b5c1ff07f1.tar.gz
Remove PGP key kludge now that AWS has published its key
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41ed4094c135..d98d72fa1337 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Steve Engledow <steve@engledow.me>
pkgname=aws-cli-v2-bin
-pkgver=2.0.41
+pkgver=2.0.44
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services version 2'
arch=('i686' 'x86_64')
@@ -12,23 +12,15 @@ makedepends=('unzip')
depends=('less')
source=(
"$pkgname-$pkgver.zip::https://awscli.amazonaws.com/awscli-exe-linux-x86_64.zip"
- "$pkgname-$pkgver.txt::https://awscli.amazonaws.com/awscli-exe-linux-x86_64.zip.sig"
- "key.txt"
+ "$pkgname-$pkgver.zip.sig::https://awscli.amazonaws.com/awscli-exe-linux-x86_64.zip.sig"
)
sha256sums=(
"SKIP"
"SKIP"
- "08234975191be290020728ad89423176430767dbd407421d02853f6fdd5ca50a"
)
-
-prepare() {
- # Check the sig but don't import the key
- # This is required because AWS haven't yet published their key to a keyserver
- # Please add your +1 to this issue https://github.com/aws/aws-cli/issues/4942
-
- gpg --dearmor key.txt
- gpg --no-default-keyring --keyring key.txt.gpg --homedir ./ --verify "$pkgname-$pkgver.txt" "$pkgname-$pkgver.zip"
-}
+validpgpkeys=(
+ "FB5DB77FD5C118B80511ADA8A6310ACC4672475C"
+)
pkgver() {
./aws/dist/aws --version | cut -d ' ' -f 1 | cut -d '/' -f 2