summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2020-12-11 22:04:39 -0500
committerChris Severance2020-12-11 22:04:39 -0500
commitb487208ec96ebeac80baade089b741051925cd36 (patch)
tree6920ef7761afe7f6cf65851e9ecd25a8d1cb14fc /PKGBUILD
parent0967c52f8bcf61781ff9527845935f97d54bb33c (diff)
downloadaur-aws-eb-cli.tar.gz
autu: Update to 3.19.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af6cced6b3ac..b777a222e1b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybasend="${_pybase//-/}"
-pkgver='3.18.2'
+pkgver='3.19.2'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,8 @@ _verwatch=("https://pypi.org/simple/${_pybasend}/" "${_pybasend}-\([0-9\.]\+\)\.
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybasend: 0:1}/${_pybasend}/${_pybasend}-${pkgver}.tar.gz")
-sha256sums=('70c247f9d54b8071d7550127e665a42a837f72812c5a1749ddb17104fbdba8db')
+md5sums=('17c706cf1d2f40ad5809aacabb498464')
+sha256sums=('bd5221c26b3c7eb64597c6ae03b76c2025ed210e68d3702819bdfa1afb015230')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -44,25 +45,26 @@ _fn_pydepends() {
# Paste in from setup.py. This function does NOT work in zsh.
local _requires="
requires = [
- 'botocore>=1.15,<1.16',
+ 'botocore>=1.19.0,<1.20.0',
'cement==2.8.2',
- 'colorama>=0.4,<1.0', # use the same range that 'docker-compose' uses
+ 'colorama>=0.2.5,<0.4.4', # use the same range that 'docker-compose' uses
'future>=0.16.0,<0.17.0',
'pathspec==0.5.9',
- 'python-dateutil>=2.1,<2.8.1', # use the same range that 'botocore' uses
- 'requests>=2.20.1,<2.21',
+ 'python-dateutil>=2.1,<3.0.0', # use the same range that 'botocore' uses
+ 'requests>=2.20.1,<=2.24',
'setuptools >= 20.0',
'semantic_version == 2.5.0',
- 'six>=1.11.0,<1.12.0',
+ 'six>=1.12.0,<=1.15.0',
'termcolor == 1.1.0',
- 'urllib3>=1.24.1,<1.25',
'wcwidth>=0.1.7,<0.2.0',
#found further down in setup.py
'PyYAML>=5.3.1,<5.4', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
+ 'urllib3>=1.25.4,<1.26',
+ # use the same ranges as 'docker-py':
'docker-compose >= 1.25.2, < 1.26.0',
'blessed>=1.9.5',
#Part of Botocore
- 'docutils<0.16,>=0.10'
+ #'docutils<0.16,>=0.10'
]
"
# Convert requires=[] to local _requires=()