summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron Miller2018-06-10 19:49:00 -0700
committerAaron Miller2018-06-10 19:50:32 -0700
commitfeb93d98e3aae1e1ee0ca1922d0396d613498ddc (patch)
tree523e3d4f3387a91d0e76e5734c367852e19d3d75 /PKGBUILD
downloadaur-feb93d98e3aae1e1ee0ca1922d0396d613498ddc.tar.gz
v0.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef0fc35aa05b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Aaron Miller <aaronm@cldtk.com>
+
+pkgname=aws-sam-cli
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='CLI tool for local development and testing of Serverless applications'
+arch=('any')
+url='https://github.com/awslabs/aws-sam-cli'
+license=('Apache')
+depends=('python')
+source=("https://github.com/awslabs/aws-sam-cli/archive/v${pkgver}.tar.gz")
+sha256sums=('227c8c9a4ad565cee58496008aa07f6ee15336b523336f9a2b404f71a0cd4b0f')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}