summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2019-01-12 17:47:52 -0500
committerTony Lambiris2019-01-12 17:47:52 -0500
commit97c086cea3e993196646393d106494574577c4c5 (patch)
tree8d9f23e80096715e51a31c9c99312ca74d5420fe /PKGBUILD
parente12ce438df7f591bd451ae789ca1273ebf19bb8d (diff)
downloadaur-97c086cea3e993196646393d106494574577c4c5.tar.gz
Fixups and version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index efe81c2b8df5..aa90dc660c2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=aws-sdk-cpp-git
-pkgver=1.7.28.r0.g7bc5b426e8
+pkgver=1.7.33.r0.gc64f092956
pkgrel=1
pkgdesc="AWS SDK for C++"
-arch=(any)
+arch=('x86_64')
url="https://github.com/aws/aws-sdk-cpp"
-license=('BSD')
+license=('Apache')
depends=('cmake')
makedepends=('openssl' 'curl' 'zlib' 'libutil-linux')
-source=("${pkgname}::git+https://github.com/aws/aws-sdk-cpp")
+_gitcommit='c18f2daa64d5968861bbb58a437fd06a9475e294'
+source=("${pkgname}::git+https://github.com/aws/aws-sdk-cpp#commit=${_gitcommit}")
+#source=("${pkgname}::git+https://github.com/aws/aws-sdk-cpp")
sha256sums=('SKIP')
-pkgver() {
- cd ${pkgname}
-
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+# disable until aws engineers can settle on their fucking build process
+#pkgver() {
+# cd ${pkgname}
+#
+# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+#}
build() {
cd ${pkgname}