summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobert Tari2021-01-28 23:07:25 +0100
committerRobert Tari2021-01-28 23:07:25 +0100
commit5f8efc1c146f0c7d6a3f1db5037a08e36d0218df (patch)
tree5046bcddf9bbb6d931c7b0969d835d30fa3ee95a /PKGBUILD
parentb842c56f7bb3020ee2d01b54148ea0ae5457abea (diff)
downloadaur-5f8efc1c146f0c7d6a3f1db5037a08e36d0218df.tar.gz
Automatic update via tari.in
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f040f2a930b..02a06855dacd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,28 +7,24 @@ pkgdesc="Ayatana Indicator for viewing recent notifications"
arch=("i686" "x86_64" "pentium4")
url="https://github.com/AyatanaIndicators"
license=("GPL3")
-depends=("glib2" "libayatana-indicator")
-makedepends=("intltool" "libayatana-indicator" "glib2" "gdk-pixbuf2" "gtk3" "mate-common")
+depends=("libayatana-indicator" "glib2" "systemd")
+makedepends=("intltool" "cmake" "cmake-extras" "glib2")
source=("https://github.com/AyatanaIndicators/${pkgname}/archive/${pkgver}.tar.gz")
md5sums=("c1197b1e1b8e10a9648937012b3b2812")
options=("!emptydirs")
-prepare()
-{
- cd ${pkgname}-${pkgver}
- NOCONFIGURE=1 ./autogen.sh
-}
-
build()
{
cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr --libexecdir=/usr/lib --disable-static
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=lib
make
}
package()
{
- cd ${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}/build
make DESTDIR="${pkgdir}" install
}