summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIngo Meyer2022-02-28 13:02:30 +0100
committerIngo Meyer2022-02-28 13:02:30 +0100
commit8a05e4515675ce61d49e725b50607c14e3afce42 (patch)
tree378d7bfb4b32ee761ab737e4709bfd09b86e3e6c /PKGBUILD
parentfc5e6b68b04d06780304281b02d7a53daafbd29c (diff)
downloadaur-8a05e4515675ce61d49e725b50607c14e3afce42.tar.gz
Add a patch to fix the non-changing status icon (GTK status icon)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 088d10bffd91..153fcb5093bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname="ayatana-webmail-no-indicator-messages"
pkgver="22.2.26"
-pkgrel="1"
+pkgrel="2"
pkgdesc="Webmail notifications and actions for any desktop without ayatana-indicator-messages dependency"
arch=("any")
url="https://tari.in/www/software/ayatana-webmail/"
@@ -13,12 +13,20 @@ depends=("hicolor-icon-theme" "dconf" "gobject-introspection" "desktop-file-util
makedepends=("python-setuptools" "python-polib")
optdepends=("ayatana-indicator-messages: Support for indicator messages")
install="ayatana-webmail.install"
-source=("ayatana-webmail-${pkgver}.tar.gz::https://github.com/AyatanaIndicators/ayatana-webmail/archive/${pkgver}.tar.gz")
-md5sums=("98ee497c3d3fa3122524c0f654163bc0")
+source=("ayatana-webmail-${pkgver}.tar.gz::https://github.com/AyatanaIndicators/ayatana-webmail/archive/${pkgver}.tar.gz"
+ "status_icon.patch")
+md5sums=("98ee497c3d3fa3122524c0f654163bc0"
+ "eb8721b75b144ab35a8e18bb352799ab")
provides=("ayatana-webmail=${pkgver}")
replaces=("unity-mail")
conflicts=("ayatana-webmail" "unity-mail")
+prepare()
+{
+ cd ayatana-webmail-${pkgver}
+ patch -Np1 -i "${srcdir}/status_icon.patch"
+}
+
build()
{
cd ayatana-webmail-${pkgver}