summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2019-07-07 22:35:20 +0200
committerFabioLolix2019-07-07 22:35:20 +0200
commitc6e046b573601875f9f5da06d96f86d4a72c411d (patch)
tree88bbdeb6e5ef9c30a46c3dec406005cc42829107 /PKGBUILD
parent382854f15cfaa2b61a2472cfe3ac44345ea3aece (diff)
downloadaur-c6e046b573601875f9f5da06d96f86d4a72c411d.tar.gz
v10.2.1, built from source. Thanks to xuanruiqi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf414f1e20e8..901492614109 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
-# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
+# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org>
# Contributor: Jonas Heinrich <onny@project-insanity.org>
pkgname=azcopy
-pkgver=7.3.0
+pkgver=10.2.1
pkgrel=1
pkgdesc="A command-line utility designed for copying data to/from Microsoft Azure"
-arch=('x86_64')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://docs.microsoft.com/en-us/azure/storage/common/storage-use-azcopy"
-license=('unknown')
-source=("${pkgname}-${pkgver}.tar.gz::https://aka.ms/downloadazcopylinux64")
-sha512sums=('7b88f1c9173c35b1153a8c0b3cd95beef6667b9ada4fea5796318a1f6b91a89431a79874d432cd3fb98fa12f6b1142ce64c81aa921fc73ace736302617052715')
-options=(!strip libtool staticlibs)
-depends=('openssl-1.0')
+license=(MIT)
+makedepends=(go dep git)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Azure/azure-storage-azcopy/archive/v${pkgver}.tar.gz")
+sha512sums=('dff5f745f457cc8b3756de00ac4bfef28412596b8dea6a2d691e6bfed48b533f80f1b843188b8aa687e4748107dc4dce2cef07d5e434c7ed72f0cd98bafb5a79')
+
+prepare() {
+ mkdir -p "${srcdir}/src/github.com/Azure"
+ mv "${srcdir}/azure-storage-azcopy-${pkgver}" "${srcdir}/src/github.com/Azure/azure-storage-azcopy"
+}
+
+build() {
+ cd "${srcdir}/src/github.com/Azure/azure-storage-azcopy"
+ go build -buildmode=pie
+}
package() {
- cd "${srcdir}/${pkgname}"
- install -d "${pkgdir}/usr/lib/azcopy"
- cp -r * "${pkgdir}/usr/lib/azcopy/"
- install -Dm755 startup "${pkgdir}/usr/bin/azcopy"
+ install -Dm755 "${srcdir}/src/github.com/Azure/azure-storage-azcopy/azure-storage-azcopy" "${pkgdir}/usr/bin/azcopy"
+ install -Dm644 "${srcdir}/src/github.com/Azure/azure-storage-azcopy/LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}