summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Baz2020-01-14 00:21:01 +0100
committerGitHub2020-01-14 00:21:01 +0100
commit6c4e902ae3373f0a92db9d74ef7b542d26d91da8 (patch)
tree385e62148185764d0605af82283e8f7a0edb02f1 /PKGBUILD
parentca86bd79e24bf7e0f890c70981057ac663e42b11 (diff)
downloadaur-6c4e902ae3373f0a92db9d74ef7b542d26d91da8.tar.gz
Fix building in chroot
When building in chroot, azure cli apparently sets python file to `/build/azure-cli/src/azure-cli/bin/python` which doesn't exist outside of chroot. This change sets the path as it will be in the real system after package installation.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93fe40fe939e..c62712622922 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=azure-cli
pkgver=2.0.79
-pkgrel=2
+pkgrel=3
pkgdesc="Command-line tools for Azure."
arch=('any')
url="https://github.com/Azure/azure-cli"
@@ -20,6 +20,7 @@ sha256sums=("9dc76481771bb2e219217187a1331a85a426e685d4070867a42d5825956ee512"
prepare() {
rm -rf "$srcdir/azure-cli"
grep -v -E '^===>|^$' install.response | python "$srcdir/install.py"
+ find $srcdir/azure-cli/bin -type f -print0 | xargs -0 sed -i -e "s|$srcdir|/opt|g"
}
pkgver() {