aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRyan Jacobs2019-08-21 06:42:18 -0700
committerRyan Jacobs2019-08-21 06:51:13 -0700
commit4450b82e4669263f5ad1c1ea899ef9e3da903e72 (patch)
treefcb2da442325c03bc944e7f53e6395d2f80e077f /PKGBUILD
parente6bf3eec8c5f2081b908c70660dbb96510ec5599 (diff)
downloadaur-4450b82e4669263f5ad1c1ea899ef9e3da903e72.tar.gz
use official udev rules provided in the git repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ea4bdd1377a..e9cfc6c482ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ryan Jacobs <ryan@rmj.us>
pkgname=azure-kinect-sensor-sdk-git
-pkgver=v1.2.0.beta.1.r4.4b37ca7d
-pkgrel=2
+pkgver=v1.2.0.beta.1.r5.aebb27ac
+pkgrel=1
pkgdesc="A cross platform user mode SDK to read data from Azure Kinect devices."
arch=("x86_64")
url="https://github.com/microsoft/Azure-Kinect-Sensor-SDK"
@@ -18,10 +18,6 @@ pkgver() {
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-prepare() {
- cp -v ../50-kinect-azure.rules .
-}
-
build() {
cd "$srcdir/${pkgname%-git}"
mkdir -p build
@@ -34,11 +30,8 @@ package() {
cd "$srcdir/${pkgname%-git}"
# make install
- cd build
- make DESTDIR="$pkgdir/" install
- cd ../../
+ make -C ./build DESTDIR="$pkgdir/" install
# install udev rule
- mkdir -p "$pkgdir/udev/rules.d"
- cp -v 50-kinect-azure.rules "$pkgdir/udev/rules.d/"
+ install -v -Dm644 ./scripts/99-k4a.rules "$pkgdir/usr/lib/udev/rules.d/99-k4a.rules"
}