aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRyan Jacobs2019-09-07 16:50:56 -0700
committerRyan Jacobs2019-09-07 16:50:56 -0700
commit59dcdf06de13d9503ea310abf7576a9068d65291 (patch)
tree923fadddaa02c5bc69515fd033807b583d0ed1e3 /PKGBUILD
parent0d814747d922b8118cebc662523bb0cd6fbd8e10 (diff)
downloadaur-59dcdf06de13d9503ea310abf7576a9068d65291.tar.gz
symlink the .so files to the standard /usr/lib/ path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e690a7904655..ec0eb04b9e6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ryan Jacobs <ryan@rmj.us>
pkgname=azure-kinect-sensor-sdk-git
pkgver=v1.2.0.beta.1.r27.467d8272
-pkgrel=5
+pkgrel=6
pkgdesc="A cross platform user mode SDK to read data from Azure Kinect devices."
arch=("x86_64")
url="https://github.com/microsoft/Azure-Kinect-Sensor-SDK"
@@ -39,4 +39,8 @@ package() {
popd
install -v -Dm644 libdepthengine.so.2.0 "$pkgdir/usr/local/lib64/libdepthengine.so.2.0"
+
+ # symlink the .so files to the standard /usr/lib/ path
+ mkdir -p "$pkgdir/usr/lib"
+ ln -s "$pkgdir/usr/local/lib64/"*.so* "$pkgdir/usr/lib"
}