summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelipe Balbi2020-05-25 18:29:47 +0300
committerFelipe Balbi2020-05-25 18:29:47 +0300
commit7c57faf50defb63e842b0f678ee8a92dfabc8164 (patch)
treea09faf0793dfb77835c26c18c8e6f9cdb7601d12 /PKGBUILD
parent02ac0b6357013d0a624c7d9271b4de583958804c (diff)
downloadaur-7c57faf50defb63e842b0f678ee8a92dfabc8164.tar.gz
Bump to 20.04
Signed-off-by: Felipe Balbi <felipe.balbi@microsoft.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb161c3d0d5f..f77bee60977e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
# Maintainer: Felipe Balbi <felipe.balbi@microsoft.com>
-pkgname=azure-sphere-sdk
-pkgver=20.01
+pkgname=azure-sphere-sdk
+pkgmajor=20
+pkgminor=04
+pkgver=${pkgmajor}.${pkgminor}
pkgrel=1
pkgdesc="Azure Sphere SDK Preview for Linux"
arch=('x86_64')
@@ -16,10 +18,10 @@ install="${pkgname}".install
optdepends=('minicom: for serial communication with the Sphere board'
'code: for software development')
options=(!strip staticlibs)
-source=("${pkgname}-${pkgver}.tar.gz::https://software-download.microsoft.com/download/pr/Azure_Sphere_SDK_Bundle_20_01.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://software-download.microsoft.com/download/pr/Azure_Sphere_SDK_Bundle_${pkgmajor}_${pkgminor}.tar.gz"
"azure-sphere-sdk.udev"
"azure-sphere-sdk.sysusers")
-sha256sums=('c7a8fabdada37e5a4d3b46aa236ddf7612b9fd8e1d90409d2169f085af9fc201'
+sha256sums=('e6c6889645386d26ac9604abbbeaaf0930bee831903b589dd647fa8313690e0a'
'649ec04bdd0c052838bf3364fdd32313264891c4f7f60039cb644ef79c3c589f'
'323c5e51b6bcf92c7e024cfd6bd6843cb57531317c6ef887b1bced81e920d43e')
@@ -34,7 +36,7 @@ build() {
chmod 755 "${srcdir}"/azurespheresdk/Tools/azsphere_slattach
chmod 755 "${srcdir}"/azurespheresdk/Tools/azsphere_connect.sh
- for sysroot in 3 4 4+Beta2001; do
+ for sysroot in `ls ${srcdir/azurespheresdk/Sysroots/`; do
chmod 755 "${srcdir}"/azurespheresdk/Sysroots/"${sysroot}"/tools/exp23-appsdk-linux-blanca.sh
"${srcdir}"/azurespheresdk/Sysroots/"${sysroot}"/tools/exp23-appsdk-linux-blanca.sh -d "${srcdir}"/azurespheresdk/Sysroots/"${sysroot}"/tools/ -y
done