summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelipe Balbi2020-12-10 13:48:28 +0200
committerFelipe Balbi2020-12-10 13:48:28 +0200
commitb95dee017748dc536c8054fa7054a2838f610fa0 (patch)
tree5e3fc7c002c4c8d148c733f9271b2b25627f5d9e /PKGBUILD
parent00e3c230a18aa679327891783175c8b089ef6db2 (diff)
downloadaur-b95dee017748dc536c8054fa7054a2838f610fa0.tar.gz
Bump to 20.11
Signed-off-by: Felipe Balbi <felipe.balbi@microsoft.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f22a21d5b91..332663adf574 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Felipe Balbi <felipe.balbi@microsoft.com>
pkgname=azure-sphere-sdk
pkgmajor=20
-pkgminor=07
+pkgminor=11
pkgver=${pkgmajor}.${pkgminor}
-pkgrel=4
+pkgrel=1
pkgdesc="Azure Sphere SDK Preview for Linux"
arch=('x86_64')
url="https://aka.ms/AzureSphereSDK"
@@ -18,10 +18,10 @@ install="${pkgname}".install
optdepends=('minicom: for serial communication with the Sphere board'
'code: for software development')
options=(!strip staticlibs)
-source=("${pkgname}-${pkgver}.tar.gz::https://software-download.microsoft.com/download/pr/Azure_Sphere_Linux_SDK_Bundle_${pkgmajor}_${pkgminor}.tar.gz"
- "azure-sphere-sdk.udev"
+source=("${pkgname}-${pkgver}.tar.gz::https://software-download.microsoft.com/download/pr/Azure_Sphere_SDK_Bundle_${pkgmajor}_${pkgminor}.tar.gz"
+ "azure-sphere-sdk.udev"
"azure-sphere-sdk.sysusers")
-sha256sums=('6987f31798a4cec202d3f85be5f47a5da5c926c5c48868626625d16407e02e26'
+sha256sums=('7d6fb0b77761be795eaeb78b4a7ecd69f08eab54c5a73a7a41478bd983dabbd2'
'649ec04bdd0c052838bf3364fdd32313264891c4f7f60039cb644ef79c3c589f'
'323c5e51b6bcf92c7e024cfd6bd6843cb57531317c6ef887b1bced81e920d43e')
@@ -33,8 +33,8 @@ build() {
find "${srcdir}" -type d -exec chmod 755 {} \;
find "${srcdir}" -type f -exec chmod 644 {} \;
chmod 755 "${srcdir}"/azurespheresdk/Tools/azsphere
- chmod 755 "${srcdir}"/azurespheresdk/Tools/azsphere_slattach
- chmod 755 "${srcdir}"/azurespheresdk/Tools/azsphere_connect.sh
+ chmod 755 "${srcdir}"/azurespheresdk/DeviceConnection/azsphere_slattach
+ chmod 755 "${srcdir}"/azurespheresdk/DeviceConnection/azsphere_connect.sh
for sysroot in `ls ${srcdir}/azurespheresdk/Sysroots/`; do
chmod 755 "${srcdir}"/azurespheresdk/Sysroots/"${sysroot}"/tools/exp23-appsdk-linux-blanca.sh
@@ -48,13 +48,15 @@ package() {
install -Dm644 "${srcdir}"/"${pkgname}".sysusers "${pkgdir}"/usr/lib/sysusers.d/"${pkgname}".conf
mkdir -p "${pkgdir}"/opt/azurespheresdk
- for DIR in BoardConfigPresets DebugTools Sysroots CMakeFiles HardwareDefinitions Tools; do
+
+ for DIR in BoardConfigPresets CMakeFiles DebugTools DeviceConnection HardwareDefinitions Sysroots \
+ Tools Tools_v2_Installer; do
cp -r "${srcdir}"/azurespheresdk/"${DIR}" "${pkgdir}"/opt/azurespheresdk
done
mkdir -p "${pkgdir}"/usr/bin
ln -s ../../opt/azurespheresdk/Tools/azsphere "${pkgdir}"/usr/bin/azsphere
- ln -s ../../opt/azurespheresdk/Tools/azsphere_connect.sh "${pkgdir}"/usr/bin/azsphere_connect.sh
- ln -s ../../opt/azurespheresdk/Tools/azsphere_slattach "${pkgdir}"/usr/bin/azsphere_slattach
+ ln -s ../../opt/azurespheresdk/DeviceConnection/azsphere_connect.sh "${pkgdir}"/usr/bin/azsphere_connect.sh
+ ln -s ../../opt/azurespheresdk/DeviceConnection/azsphere_slattach "${pkgdir}"/usr/bin/azsphere_slattach
}