summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Turner2017-11-16 03:53:04 -0500
committerWilliam Turner2017-11-16 03:53:04 -0500
commit6b401e99f2be063fef671f0191803f0d6d601a16 (patch)
treec9c51ac71fd57a58c3715f1e7e47d73b419274d0 /PKGBUILD
downloadaur-6b401e99f2be063fef671f0191803f0d6d601a16.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f7ff1206336
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgname=sqlops
+pkgver=0.23.6
+pkgrel=1
+pkgdesc="SQL Operations Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux."
+arch=('x86_64')
+url="https://github.com/Microsoft/sqlopsstudio"
+license=('custom: microsoft')
+depends=('fontconfig' 'libxtst' 'gtk2' 'python' 'cairo' 'alsa-lib' 'nss' 'gcc-libs' 'glibc' 'libxss' 'gconf' 'libxkbfile' 'libunwind' 'libsecret' 'curl')
+options=('staticlibs')
+source=("http://download.microsoft.com/download/4/E/B/4EB84B63-4532-40D4-A1CD-8FD5772971CF/sqlops-linux-${pkgver}.tar.gz")
+sha256sums=('854039f310171005e1e78a7aac9751803374926d60b7c4f83683815a32c3e66a')
+
+package() {
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/opt/${pkgname}"
+
+ install -m644 "${srcdir}/sqlops-linux-x64/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cp -r "${srcdir}/sqlops-linux-x64/"* "${pkgdir}/opt/${pkgname}"
+ ln -s /opt/${pkgname}/bin/sqlops "${pkgdir}/usr/bin/sqlops"
+}