summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Turner2018-02-12 16:07:33 -0500
committerWilliam Turner2018-02-12 16:07:33 -0500
commit9994268125b21cbf37b78b10716c2bd31d34612f (patch)
tree245ece41f6636ecd662bf1392b79ec3ba72ef9fa /PKGBUILD
parent439ec208c699dd1868bf9096633a588bbda8e851 (diff)
downloadaur-9994268125b21cbf37b78b10716c2bd31d34612f.tar.gz
Bump to 0.26.3 and add .desktop file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9c96e6c42a9..8fe94a4b963f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: William Turner <willtur.will@gmail.com>
pkgname=sqlops
-pkgver=0.25.4
+pkgver=0.26.3
pkgrel=1
pkgdesc="SQL Operations Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux."
arch=('x86_64')
@@ -9,16 +9,22 @@ license=('custom: microsoft')
depends=('fontconfig' 'libxtst' 'gtk2' 'python' 'cairo' 'alsa-lib' 'nss' 'gcc-libs' 'glibc' 'libxss' 'gconf' 'libxkbfile' 'libunwind' 'libsecret' 'curl')
optdepends=('krb5: Windows authentication support')
options=('staticlibs')
-source=("https://github.com/Microsoft/sqlopsstudio/releases/download/${pkgver}/sqlops-linux-${pkgver}.tar.gz")
-sha256sums=('af259da7df87ddd376296aca5a6b174289e02d2737d248ad28cd8a7123316562')
+source=("https://github.com/Microsoft/sqlopsstudio/releases/download/0.26.1/sqlops-linux-0.26.3.tar.gz"
+ 'sqlops.desktop')
+sha256sums=('f8387cb34ad1f15e86f3ca9e8392a1a64bbdef4da25d505e1e4779add4e5a0a8'
+ 'b5ad95bef9b56aba179c642e0edac04c32aa8cb3c4c0428cf0257119995e1dc2')
package() {
- install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "${pkgdir}/usr/share/${pkgname}"
+ cp -r "${srcdir}/sqlops-linux-x64/"* "${pkgdir}/usr/share/${pkgname}"
+
+ # Symlink the startup script in /usr/bin
install -d "${pkgdir}/usr/bin"
- install -d "${pkgdir}/opt/${pkgname}"
+ ln -s "/usr/share/${pkgname}/bin/sqlops" "${pkgdir}/usr/bin/sqlops"
- install -m644 "${srcdir}/sqlops-linux-x64/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Add the .desktop file
+ install -D -m644 "${srcdir}/sqlops.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- cp -r "${srcdir}/sqlops-linux-x64/"* "${pkgdir}/opt/${pkgname}"
- ln -s /opt/${pkgname}/bin/sqlops "${pkgdir}/usr/bin/sqlops"
+ # Install the license file
+ install -D -m644 "${srcdir}/sqlops-linux-x64/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}