summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Turner2018-10-22 15:31:58 -0400
committerWilliam Turner2018-10-22 15:31:58 -0400
commitf240f941a6daf40c586e7730e61ad57c1a108af2 (patch)
treebce1cd4c38d3e091a7f40ee788985cab8438466f /PKGBUILD
parent99afc8361ea7bf4d6f5c95d22e8868f7dce0c30c (diff)
downloadaur-f240f941a6daf40c586e7730e61ad57c1a108af2.tar.gz
Rebrand as ADS and bump to 1.1.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc5574b67d69..62c71b2ab0d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: William Turner <willtur.will@gmail.com>
-pkgname=sqlops
-_pkgname=azuredatastudio
-pkgver=1.0.0
+pkgname=azuredatastudio
+pkgver=1.1.3
pkgrel=1
pkgdesc="Azure Data Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW (formerly SQL Operations Studio)."
arch=('x86_64')
@@ -10,26 +9,28 @@ license=('custom: microsoft')
depends=('fontconfig' 'libxtst' 'gtk2' 'python' 'cairo' 'alsa-lib' 'nss' 'gcc-libs' 'glibc' 'libxss' 'gconf' 'libxkbfile' 'libunwind' 'libsecret' 'curl')
makedepends=('sed')
optdepends=('krb5: Windows authentication support')
+provides=('sqlops')
+conflicts=('sqlops')
options=('staticlibs')
-source=("https://github.com/Microsoft/${_pkgname}/releases/download/${pkgver}/${_pkgname}-linux-${pkgver}.tar.gz"
- "${_pkgname}.desktop")
-sha256sums=('d5f1119abc16fa3f6dc50cd804251151a4052f5c8781bd734fe38da8b8007f4a'
+source=("https://github.com/Microsoft/${pkgname}/releases/download/${pkgver}/${pkgname}-linux-${pkgver}.tar.gz"
+ "${pkgname}.desktop")
+sha256sums=('46aefa7549bfe1f3d31e777accfc76bc1be13de8c98c194a86078bb7bdc1c3d4'
'42299d94a2b355c07a91f3c54bd79f6aa65c69dc1063689caad288be2d6c650b')
package() {
- install -d "${pkgdir}/usr/share/${_pkgname}"
- cp -r "${srcdir}/${_pkgname}-linux-x64/"* "${pkgdir}/usr/share/${_pkgname}"
+ install -d "${pkgdir}/usr/share/${pkgname}"
+ cp -r "${srcdir}/${pkgname}-linux-x64/"* "${pkgdir}/usr/share/${pkgname}"
# Symlink the startup script in /usr/bin
install -d "${pkgdir}/usr/bin"
- ln -s "/usr/share/${_pkgname}/bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ ln -s "/usr/share/${pkgname}/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
# Also add an alias for the previous name to hopefully not break things too much
- ln -s "/usr/share/${_pkgname}/bin/${_pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ ln -s "/usr/share/${pkgname}/bin/${pkgname}" "${pkgdir}/usr/bin/sqlops"
# Add the .desktop file
- install -D -m644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- sed -i "s/{pkgname}/${_pkgname}/g" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ sed -i "s/{pkgname}/${pkgname}/g" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
# Install the license file
- install -D -m644 "${srcdir}/${_pkgname}-linux-x64/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "${srcdir}/${pkgname}-linux-x64/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}