summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2023-07-10 13:46:02 +1000
committerMark Blakeney2023-07-10 13:46:02 +1000
commitcd399f0f47efe17ec219b76d15df5e4908265fc3 (patch)
tree8accdcc24e0a1c4996195f1169fd4b9d4c42d4cc /PKGBUILD
parentdc02fabe0ee6f9129aa79c7f9af729e35cd2569c (diff)
downloadaur-cd399f0f47efe17ec219b76d15df5e4908265fc3.tar.gz
Update to 1.14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ebac44d91d79..db86b4835d8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=b2restore
-pkgver=1.13
+pkgver=1.14
pkgrel=1
pkgdesc="Program to recreate Backblaze B2 file archive at specified date+time."
url="https://github.com/bulletmark/$pkgname"
-license=(GPL3)
-arch=(any)
-depends=("python>=3.5")
-makedepends=(python-setuptools python-build python-installer python-wheel)
+license=("GPL3")
+arch=("any")
+depends=("python>=3.6")
+makedepends=(python-setuptools python-build python-installer
+ python-wheel python-setuptools-scm)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-md5sums=('aba12beac56f9524617a4dcb6999642e')
+sha1sums=('8ac1b7c76d6a6c292ae6de190492df5e5111245f')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver" python -m build --wheel --no-isolation
}
package() {