summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Manna2023-02-22 11:11:19 -0600
committerKyle Manna2023-02-22 11:13:29 -0600
commitf7216f34dd7aef54a3fea7a54396e39b0abdbb7e (patch)
tree0f82e83f44b7e111e8832b71ffb5aec551624242 /PKGBUILD
parentcbf09e2350dea09b28113fddac8119d96e283227 (diff)
downloadaur-f7216f34dd7aef54a3fea7a54396e39b0abdbb7e.tar.gz
pkgrel: Update to PEP 517 build and fix dependencies
* Fix dependencies to work. * Patch setup.py to be less strict. Re-occurring theme. * Thanks to @intelfx on AUR for pointing this out.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c1835e3ef81..c7e4603beb9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=backblaze-b2
_pkgname=b2
pkgver=3.7.1
-pkgrel=1
+pkgrel=2
pkgdesc='Backblaze B2 Command Line Client'
url='https://github.com/Backblaze/B2_Command_Line_Tool'
depends=('python'
@@ -15,8 +15,10 @@ depends=('python'
'python-tabulate>=0.8.10'
)
makedepends=('python-pip'
- 'python-setuptools'
+ 'python-build'
+ 'python-installer'
'python-setuptools-scm'
+ 'python-wheel'
)
# MIT or Creative Commons: https://www.backblaze.com/using_b2_code.html
@@ -33,13 +35,14 @@ build() {
sed -i -e 's:\(arrow>=.*\),.*:\1:' requirements.txt
sed -i -e 's:\(docutils==.*\):docutils>=0.16:' requirements.txt
sed -i -e 's:\(tabulate==.*\):tabulate<0.10:' requirements.txt
+ sed -i -e "s:'\(setuptools_scm\)<.*':'\1':" setup.py
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd ${srcdir}/${_pkgname}-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
# uu-coreutils messes up the directory permissions (644, expect 755)
#install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"