summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-11-06 15:03:59 +0800
committerzxp198210052023-11-06 15:03:59 +0800
commit314afb7000bda5e5d5b0b0127ba42393cdc5b066 (patch)
treee6adf2ac7094ea7781c4920ac49802850ba067d9 /PKGBUILD
parent689bfc8139133904d39b26379e8c21991c341587 (diff)
downloadaur-314afb7000bda5e5d5b0b0127ba42393cdc5b066.tar.gz
update to 23.09.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49fbab26d759..0e47d254a6b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,22 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=23.09.3
+pkgver=23.09.4
pkgrel=1
pkgdesc="Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
-arch=("aarch64" "x86_64")
+arch=(
+ "aarch64"
+ "x86_64"
+)
url="https://www.backend.ai/"
_githuburl="https://github.com/lablup/backend.ai-webui"
license=('LGPL3')
provides=("${pkgname%-bin}=${pkgver}")
-conflicts=("${pkgname%-bin}" "${_pkgname%-desktop}" "${_pkgname}")
+conflicts=(
+ "${pkgname%-bin}"
+ "${_pkgname%-desktop}"
+ "${_pkgname}"
+)
depends=(
'bash'
'electron26'
@@ -24,8 +31,8 @@ source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_githuburl}/releases/d
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
sha256sums=('27e8e3578355522309a16c4812b43e11f4632196060696b2705a8fca9a65c3f3')
-sha256sums_aarch64=('6fefe8314da172bc1d6b2a7207cbc5e717dec9868185ee40d3ade49c1b1b4f69')
-sha256sums_x86_64=('ca2f42e27fa9725a04ff694bebd0b86bf5c98bc50a84739560f3032daa619bac')
+sha256sums_aarch64=('dea0a33006b43f76d0128bb4189e2305acef2eefc641c723bf5f09b160d1bd01')
+sha256sums_x86_64=('6c2cd2bad9e2b63835327e8b9215de721906fcf18a35a82b7ca425051d7a22be')
build() {
gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories "Development" --name "${pkgname%-bin}" --exec "${pkgname%-bin}"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"
@@ -38,4 +45,4 @@ package() {
"${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
done
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
-} \ No newline at end of file
+}