summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-02-23 13:02:28 +0800
committerzxp198210052024-02-23 13:02:28 +0800
commit9532f1113ecf3abc4353b367b9733e03a92afbe0 (patch)
treea50230bdc762d9372ce6b32c37e711f544d81dc5 /PKGBUILD
parent9aba318651c81eafba1347bdf3ea1825e992f45a (diff)
downloadaur-9532f1113ecf3abc4353b367b9733e03a92afbe0.tar.gz
update to 23.09.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed2708199e54..5c0a44702867 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=23.09.8
+pkgver=23.09.9
_electronversion=26
pkgrel=1
pkgdesc="Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
@@ -12,7 +12,7 @@ arch=(
)
url="https://www.backend.ai/"
_ghurl="https://github.com/lablup/backend.ai-webui"
-license=('LicenseRef-LGPL3')
+license=('LGPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=(
"${pkgname%-bin}"
@@ -31,14 +31,14 @@ source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_ghurl}/releases/downl
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
-sha256sums_aarch64=('59846be5ab2bf4378581b9c9e4784ac61a48bc83f7be1c7a6db0890db58d49a2')
-sha256sums_x86_64=('05c504a0054df575f2814878e8e97ce373bed72ae66b0bfa26cb2e7e8ac04a71')
+sha256sums_aarch64=('1f1a905b2501d11a554c7a45000f9b0de6adf5925a4e648bebcf70452fe7ad9f')
+sha256sums_x86_64=('8c6474d76516aac0bd54635b2331ecc3f2983f4f4a3f5512f3fbff8788a2bb2e')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories "Development" --name "${pkgname%-bin}" --exec "${pkgname%-bin} %U"
+ gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories="Development" --name="${pkgname%-bin}" --exec="${pkgname%-bin} %U"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"
}
package() {