summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-04-08 09:11:22 +0800
committerzxp198210052024-04-08 09:11:22 +0800
commiteed1d2a10d634a29033abbd05b3c712992c8d29e (patch)
tree12d00b957513af143c60149d4a958b9ac5af4230 /PKGBUILD
parentac9525aa746a81092eecc9ecaf951d6bd8764913 (diff)
downloadaur-eed1d2a10d634a29033abbd05b3c712992c8d29e.tar.gz
update to 23.09.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3637374bb58a..75839cbbf5cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=23.09.9
-_electronversion=26
-pkgrel=2
+pkgver=23.09.10
+_electronversion=29
+pkgrel=1
pkgdesc="Provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=(
"aarch64"
@@ -33,13 +33,13 @@ source=(
)
sha256sums=('c54209c33c387908bfaae40a9c5f6c96bacaa52684f2546068e2b4441f4a53b3'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
-sha256sums_aarch64=('1f1a905b2501d11a554c7a45000f9b0de6adf5925a4e648bebcf70452fe7ad9f')
-sha256sums_x86_64=('8c6474d76516aac0bd54635b2331ecc3f2983f4f4a3f5512f3fbff8788a2bb2e')
+sha256sums_aarch64=('5db7712dba826cd7486b819a6da606151f12225c8e6ce666dd7ff7f47cea3352')
+sha256sums_x86_64=('aa2ac499547f41fa2719cea81983c52a22150bae987fc1672ebbfa9c90323106')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
- -e "s|@options@||g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories="Development" --name="${pkgname%-bin}" --exec="${pkgname%-bin} %U"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"