summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2023-01-03 14:18:17 -0500
committergraysky2023-01-03 14:18:17 -0500
commita9a21b0e178b919a57e0a442e4b399ffeabd829a (patch)
tree51c94c70ce7471a37a848f7c34964a4b77b2d58a /PKGBUILD
parent3dad0dabf612d29c43e5c2d34d5b2dcc0a711c67 (diff)
downloadaur-a9a21b0e178b919a57e0a442e4b399ffeabd829a.tar.gz
Update to 1.3.3-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28f7aac8a9fc..610d6029bc37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,59 +3,58 @@
pkgname=(backintime backintime-cli)
_pkgname="backintime"
-pkgver=1.3.2
-pkgrel=2
+_commit=8495f9dc3953343a0352bb3ffbdcfab7f93c10ad
+pkgver=1.3.3
+pkgrel=1
arch=(any)
url="https://github.com/bit-team/backintime"
license=(GPL)
makedepends=(python)
-checkdepends=(openssh python-dbus rsync systemd)
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz"
- 001-fix-test-test_tools-add-sleep-for-flaky-systems.patch::https://patch-diff.githubusercontent.com/raw/bit-team/backintime/pull/1214.patch)
-b2sums=('64d312ca8f140bf42ed8d41cb915adc8e181e535e13f9a2b2f1cee9c8ab18254df15604b869f98e5978cb204d558eaf602ea3d158a52527843ba2c045d702545'
- 'f840b40cebb5a360db319fddb404217cff94e62df36e155ebd41ff44cf357a29697c461e83b878d044230f902b91beaaccf604d12e68d93f58c0b5360237cb7e')
+checkdepends=(openssh python-dbus rsync systemd python-pyfakefs)
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/$_commit.tar.gz")
+b2sums=('5900c265718d3d3fad1ce3e38719c6e12cb435105d0b714a4602e1a541d3610d8cb552e13a1c59acf2bfc67290637fc2aacae971865d67fcfad92ad85a64d161')
prepare() {
- cd "$_pkgname-$pkgver"
- patch -p1 -i ../001-fix-test-test_tools-add-sleep-for-flaky-systems.patch
+ cd "$_pkgname-$_commit"
}
build() {
- cd "$_pkgname-$pkgver/common"
+ cd "$_pkgname-$_commit/common"
./configure --python --no-fuse-group
make
- cd "$srcdir/$_pkgname-$pkgver/qt"
+ cd "$srcdir/$_pkgname-$_commit/qt"
./configure --python
make
}
check() {
- cd "$_pkgname-$pkgver/common"
+ cd "$_pkgname-$_commit/common"
+
make test
}
package_backintime-cli() {
pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."
- depends=('cron' 'fuse2' 'openssh' 'python-dbus' 'python-keyring' 'rsync')
+ depends=(cron fuse2 openssh python-dbus python-keyring rsync python-packaging python-pyfakefs)
optdepends=('backintime: QT5 GUI version'
'encfs: encrypted filesystem in user-space'
'pm-utils: for laptops allows an option to not snapshot on battery'
'sshfs: FUSE client based on the ssh file transfer protocol')
- cd "$_pkgname-$pkgver/common"
+ cd "$_pkgname-$_commit/common"
make DESTDIR="$pkgdir" install
}
package_backintime() {
pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. QT5 GUI version."
- depends=("backintime-cli=$pkgver" 'libnotify' 'polkit' 'python-dbus' 'python-pyqt5' 'xorg-xdpyinfo')
+ depends=("backintime-cli=$pkgver" libnotify polkit python-dbus python-pyqt5 xorg-xdpyinfo)
# note users can optionally install EITHER kompare OR meld but not both!
optdepends=('kompare: diff/patch frontend'
'meld: diff/patch frontend'
'python-keyring: store and access passwords safely')
- cd "$_pkgname-$pkgver/qt"
+ cd "$_pkgname-$_commit/qt"
make DESTDIR="$pkgdir" install
}