summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2022-03-12 09:26:51 -0500
committergraysky2022-03-12 09:26:53 -0500
commitb1b4129cd34d219000e61221fce49d918973c722 (patch)
treedd2c649bf51851a7d34f1eb595cc968933ae4b57 /PKGBUILD
parente7bbb7f94dfb243b263e947820705f3342bc4cae (diff)
downloadaur-b1b4129cd34d219000e61221fce49d918973c722.tar.gz
Update to 1.3.2-1
update and disable checks due to https://github.com/bit-team/backintime/issues/1234
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 799771065cd3..c289a94c3801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,20 @@
pkgname=(backintime backintime-cli)
_pkgname="backintime"
-pkgver=1.3.1
-pkgrel=4
+pkgver=1.3.2
+pkgrel=1
arch=(any)
url="https://github.com/bit-team/backintime"
license=(GPL)
makedepends=(python)
checkdepends=(openssh python-dbus rsync systemd)
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/$pkgver.tar.gz"
-0001-make-tools.py-work-on-python-3.10.patch::https://patch-diff.githubusercontent.com/raw/bit-team/backintime/pull/1174.patch)
-b2sums=('b5bea6aad750ffe133d650af9b957500f857fabc9ab14e7e02abe2e7cc3bad806c609f76c5f553e764435b3ab5b5096d21c7329bd7497814f8a4ab23cb58f49f'
- '060784876df4be67324b49452b6382e542ba22071483ae1594e738e0480395415c84207fce66374be859f477b7e53f80fd8e0ef9ed93f1495b31b56f2387e52d')
-
-prepare() {
- cd "$_pkgname-$pkgver"
- patch -Np1 -i ../0001-make-tools.py-work-on-python-3.10.patch
-}
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
+b2sums=('64d312ca8f140bf42ed8d41cb915adc8e181e535e13f9a2b2f1cee9c8ab18254df15604b869f98e5978cb204d558eaf602ea3d158a52527843ba2c045d702545')
+
+#prepare() {
+# cd "$_pkgname-$pkgver"
+# patch -p1 -i ../
+#}
build() {
cd "$_pkgname-$pkgver/common"
@@ -30,10 +28,10 @@ build() {
make
}
-check() {
- cd "$_pkgname-$pkgver/common"
- make test
-}
+#check() {
+# cd "$_pkgname-$pkgver/common"
+# make test
+#}
package_backintime-cli() {
pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."