summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSwift Geek2015-11-22 02:16:00 +0100
committerSwift Geek2015-11-22 02:16:52 +0100
commit700e6cf031576ae30369371770cec41348d302f1 (patch)
treefd9848adbb6ec6c32802560f45cdc9b128f6c312 /PKGBUILD
parent20a3e8ab7379463537657acfa2eae5ec77afc683 (diff)
downloadaur-700e6cf031576ae30369371770cec41348d302f1.tar.gz
Initial support for kernel forks like linux-ck, grsec #2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b2009e452ee..d1c05de830b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,10 +23,14 @@ url='https://backports.wiki.kernel.org/index.php/Main_Page'
arch=('i686' 'x86_64')
license=('GPL')
depends=('linux')
-# TODO: array for different forks like linux-ck, linux-grsec
-if [ "$_kernelname" == 'ARCH' ]; then
- makedepends=('linux-api-headers' "linux-headers>=$_shortkernver")
-fi
+
+# Assocative array for different forks like linux-ck, linux-grsec
+declare -A linfork
+linfork["ARCH"]=''
+linfork["grsec"]='-grsec'
+linfork["ck"]='-ck'
+makedepends=('linux-api-headers' "linux-headers${linfork[${_kernelname}]}>=$_shortkernver")
+
optdepends=('backports-frag+ack: wl-frag+ack patch')
install=backports.install
# Stable and rc? TODO: Check with rc :D | Double %% cuts to the first, single % cuts to the last