summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2024-07-02 23:43:52 +0200
committerMichal Wojdyla2024-07-02 23:43:52 +0200
commitca81db97f0eb0811af45078a56e5ec4a75670166 (patch)
tree8b029a7c77ba33ce1a5a97b393db5263cca10757 /PKGBUILD
parent553a20486d011b29ade6791fc4d0e96a37cdf27f (diff)
downloadaur-ca81db97f0eb0811af45078a56e5ec4a75670166.tar.gz
shadow stack
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cc4b3f7cb6f..a3a014c88ff3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=backseat-signed
pkgver=0.1.0
-pkgrel=2
+pkgrel=3
pkgdesc=' Authenticate cryptographic links from a signed derivate to its source input.'
url='https://crates.io/crates/backseat-signed'
arch=('x86_64')
@@ -19,12 +19,12 @@ prepare() {
build() {
cd $pkgname-$pkgver
- cargo build --frozen --release
+ RUSTFLAGS='-C link-args=-Wl,-z,shstk' cargo build --frozen --release
}
check() {
cd $pkgname-$pkgver
- cargo test --frozen
+ RUSTFLAGS='-C link-args=-Wl,-z,shstk' cargo test --frozen
}
package() {