summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLéo2023-09-19 21:18:36 +0200
committerLéo2023-09-19 21:18:36 +0200
commit1e0eedc69d49c326c907f81289b41c92b18515d2 (patch)
tree25d41d47b57ffd9e06cf277dc4bec192ca9e350b /PKGBUILD
parent37aff4ce790f674f164191a980f411fedd85d9f8 (diff)
downloadaur-badwolf.tar.gz
Bump to 1.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7cad2d6baa7a..86fda37dab1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: Leia <waste at mrtino dot eu>
+# Maintainer: Léo <waste at mrtino dot eu>
pkgname=badwolf
-pkgver=1.2.2
-pkgrel=2
+pkgver=1.3.0
+pkgrel=1
pkgdesc="A minimalist and privacy-oriented WebKitGTK+ browser."
url="https://hacktivis.me/projects/badwolf"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
license=('BSD')
-#makedepends=('clang') # if you want to use clang instead of gcc, decomment this line and change CC=gcc to CC=clang in the build section
-depends=('webkit2gtk')
+makedepends=('ninja' 'ed')
+depends=('webkit2gtk' 'libxml2')
source=("https://hacktivis.me/releases/$pkgname-$pkgver.tar.gz")
-sha512sums=('0f7bd28ab9bae51323082bad172914009ba979cc9f990a782f7f032ca65589284708ffcaa530f737ecd3d00b580000988b5d18fbb2643ce0df3bc001a58ef611')
+sha512sums=('f83884f9a1c4d12d641f68697d7fab7885803975ead6cb78e88b0b8d2f7b6f9da116f72e39f02c47e8dca89e4ced9b932524338a6211c7d4509c12206c10cdeb')
changelog=changelog
build() {
cd "$pkgname-$pkgver"
PREFIX=/usr ./configure
- make
+ ninja
}
package() {
cd "$pkgname-$pkgver"
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname"
- make PREFIX=/usr DESTDIR="$pkgdir/" install
+ DESTDIR="${pkgdir}/" ninja install
}