summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraxionl2019-11-22 20:07:04 +0800
committeraxionl2019-11-22 20:07:04 +0800
commit03eacb73260674697ccbdf12eada39f87b4a3ee5 (patch)
tree749617abd689a61a2cd73dfa783095bc60a84ff8 /PKGBUILD
parent4704cca7f295e015b37161ddadf42172c653c4fe (diff)
downloadaur-03eacb73260674697ccbdf12eada39f87b4a3ee5.tar.gz
[Update] baidunetdisk-bin: v3.0.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e200f2aefb6..e450b2b3d493 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Contributor: lilydjwg <lilydjwg at gmail dot com>
_pkgname=baidunetdisk
pkgname=baidunetdisk-bin
-pkgver=2.0.2
-pkgrel=2
+pkgver=3.0.1.2
+pkgrel=1
+_subver=2
pkgdesc="Baidu Net Disk is a cloud storage client (Linux Version)."
arch=('x86_64')
depends=('libxss' 'gtk3' 'nss')
@@ -20,12 +21,16 @@ source=("LICENSE.html::https://pan.baidu.com/disk/duty/index.html"
"0001-baidunetdisk-bin-deksktop-file.patch"
"baidunetdisk-wrapper.sh")
-source_x86_64=("${pkgname}-${pkgver}.deb::https://issuecdn.baidupcs.com/issue/netdisk/LinuxGuanjia/${pkgver}/${_pkgname}_linux_${pkgver}.deb")
+source_x86_64=("${pkgname}-${pkgver}.deb::https://issuecdn.baidupcs.com/issue/netdisk/LinuxGuanjia/${pkgver}/${_pkgname}_linux_${pkgver}.${_subver}.deb")
sha256sums=('80f8835a1d742ac9aa05701dfc2566b1db07b626d70e0e463688c9b5e4736e1d'
'd72eb6fa07abc0e7c2298fcecbe4a4e6849c63a6a31c39706e0dfea870e85aff'
'c0035e038344a154421301b7855c274049ad432a5b06b52efc74831daa73e02e')
-sha256sums_x86_64=('24b825423d46724d9695677809821673af0a30731edb8393e578164710acc141')
+sha256sums_x86_64=('40eb1950af62a8b9b75da8ffb9a74416ae0d3fc886b07f6de7d63673683b1ef3')
+
+pkgver() {
+ printf "%s.%s" ${pkgver} ${_subver}
+}
prepare() {
bsdtar -xpf "data.tar.xz"