summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2019-09-30 14:10:45 +0200
committerMartchus2019-09-30 14:10:45 +0200
commit68b78603f5d9438ce3d2839d4095fca092d01fe6 (patch)
tree0b4855d81b351cc21f285d2392522933bf83d130 /PKGBUILD
parent0a9c66bba9aaaacec52bf104714d4036b222d542 (diff)
downloadaur-68b78603f5d9438ce3d2839d4095fca092d01fe6.tar.gz
Add patch to fix issue with Thunderbird address book
See * https://github.com/sabre-io/Baikal/issues/819 * https://github.com/sabre-io/dav/issues/1178
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d29cda71d657..497b9aa3591b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=baikal
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='Lightweight CalDAV+CardDAV server'
url='http://sabre.io/baikal/'
arch=('any')
@@ -11,14 +11,24 @@ license=('GPL')
depends=('php')
optdepends=('sqlite: Database' 'mariadb: Alternate database' 'php-sqlite: To use the sqlite backend')
source=("https://github.com/fruux/Baikal/releases/download/$pkgver/baikal-$pkgver.zip"
- 'baikal.install')
+ 'baikal.install'
+ 'Fixed-getcontenttype-being-null.patch::https://github.com/sabre-io/dav/commit/7badab41ca48b2705426907d533aca374ba6401f.patch')
sha1sums=('47398b00cad4330bfac9df8abc03df896e2d206f'
- 'deb948e61c3cd8d6ad560321f78c0b288f7a6210')
+ 'deb948e61c3cd8d6ad560321f78c0b288f7a6210'
+ '955a7957e013b6f643d53b5d6c648c52d42550b9')
options=('!strip')
install=baikal.install
+prepare() {
+ cd "${srcdir}/baikal/vendor/sabre/dav"
+
+ # fix https://github.com/sabre-io/Baikal/issues/819 / https://github.com/sabre-io/dav/issues/1178
+ patch -p1 -i "$srcdir/Fixed-getcontenttype-being-null.patch"
+}
+
package() {
cd "${srcdir}/baikal"
+
install -dm 755 "$pkgdir"/usr/share/{webapps,doc}"/$pkgname"
install -dm 700 -o http -g http "$pkgdir/var/lib/$pkgname"
cp -R Core html vendor "$pkgdir/usr/share/webapps/$pkgname"