summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGary DeLaney2015-08-11 17:51:56 -0500
committerGary DeLaney2015-08-11 17:51:56 -0500
commit720e9a589a7f6e2b7f3afd0572fd002eed9c1c3b (patch)
treefe4f71947f5a89fa8ffec31e16ca2f770e25e3b1 /PKGBUILD
downloadaur-720e9a589a7f6e2b7f3afd0572fd002eed9c1c3b.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe07406f5cdb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: gld1982ltd <gld1982ltd@gmail.com>
+
+pkgname=bake
+pkgver=0.1.49
+pkgrel=1
+pkgdesc="An easy to use build system. Designed to be make/autotools for the 21st century. (with Semplice Linux patches)"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/bake"
+license=("GPL3")
+provides=("${pkgname%-sl}")
+conflicts=("${pkgname%}" "${pkgname%-sl}")
+makedepends=('itstool' 'vala')
+source=("https://launchpad.net/bake/0.1/${pkgver}/+download/bake-${pkgver}.tar.gz"
+ "https://github.com/semplice/bake/compare/gir_lookup.patch"
+ "https://github.com/semplice/bake/compare/python_version.patch"
+)
+md5sums=('20eda033c1482900da0cccfb90a77f6d'
+ 'SKIP'
+ 'SKIP'
+)
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i ${srcdir}/gir_lookup.patch
+ patch -p1 -i ${srcdir}/python_version.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+ ./bake-bootstrap --configure install-directory="$pkgdir/"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./bake-bootstrap install
+}