summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew McGinn2020-10-12 10:31:44 -0400
committerMatthew McGinn2020-10-12 10:31:44 -0400
commit8e98e5ee79cdfdeb172ba46950b16ceec86ea9c0 (patch)
tree7b3e0086d8991fbb8f4f950c6faea10079769c4d /PKGBUILD
parent42c4759f2a6646b9378cfbe007c9fd5ec61ccc6d (diff)
downloadaur-balena-engine.tar.gz
update build process
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffc6d061cd5f..d913e3c02935 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@ url='https://www.balena.io/'
_github_url='https://github.com/balena-os/balena-engine'
license=('Apache')
depends=('glibc' 'bridge-utils' 'iproute2' 'device-mapper' 'sqlite' 'libsystemd'
- 'libseccomp' 'libtool' 'btrfs-progs')
-makedepends=('git' 'go>=1.10.8' 'cmake' 'systemd')
+ 'libseccomp' 'libtool' 'btrfs-progs')
+makedepends=('git' 'go>=1.10.8' 'cmake' 'systemd' 'docker')
optdepends=('lxc: lxc backend support')
# don't strip binaries! A sha1 is used to check binary consistency.
options=('!strip' '!buildflags')
@@ -38,7 +38,7 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}/"
echo -n $(git describe --tags --always | sed 's/^v//;s/-/./g') > VERSION
- ./build.sh
+ make
}
package() {