summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVojtech Kral2021-05-28 00:52:05 +0200
committerVojtech Kral2021-05-28 00:52:05 +0200
commitf7af83000f8b2e6c9c91c5403208fcfbdef8c91a (patch)
tree61879167624874200a13ed4d8bb63dcf2b7ec5db /PKGBUILD
parent6aee286e81f2fd991e96e9387b4e85c0bfe7a6f9 (diff)
downloadaur-f7af83000f8b2e6c9c91c5403208fcfbdef8c91a.tar.gz
v1.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5814b64db79c..51c5e6518e18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Vojtech Kral ❬vojtech%kral.hk❭
pkgname=bard
-pkgver=1.0.3
-pkgrel=2
+pkgver=1.1.0
+pkgrel=1
pkgdesc="Creates PDF and HTML songbooks out of easy-to-write Markdown sources."
arch=('x86_64')
url="https://github.com/vojtechkral/bard"
@@ -11,19 +11,17 @@ depends=()
optdepends=('texlive-bin: TeX engine (generate PDFs) '
'tectonic: Alternative TeX engine (generate PDFs) ')
source=("$pkgname-$pkgver.tar.gz::https://github.com/vojtechkral/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('c55cb0e263e721c7faddb670493b3ad29a1e040e973e1be58fefef510b0a9e8c')
+sha256sums=('05011671d8bce6436985cd34d73ffb2c4c8980bf3a4b8891cd5dd07df4176705')
build() {
cd "$pkgname-$pkgver"
cargo build --release --locked
}
-# Not using check as that would require xelatex and tectonic
-# to build the default and example projects...
-# check() {
-# cd "$pkgname-$pkgver"
-# cargo test --release --locked
-# }
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked
+}
package() {
cd "$pkgname-$pkgver"