summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeff Sharpe2019-02-20 22:41:54 -0800
committerJeff Sharpe2019-02-20 22:41:54 -0800
commit8d1668260b8d177d444147761cb11335aa135007 (patch)
tree160326e6db59583c864a4f49c03cb9bfb9c1eb37 /PKGBUILD
parentfc3400aa053a378f50cdbc6e0383e1914e228a8d (diff)
downloadaur-8d1668260b8d177d444147761cb11335aa135007.tar.gz
Fix to SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 44 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf4a489b2205..9dc85d45f66c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,60 @@
-# Maintainer: kaptoxic
+# Maintainer: olddog <jeff@impcode.com>
+# Contributer: kaptoxic
# Contributor: carloratm <carlo.ratm@gmail.com>
pkgname=barman
_realname=barman
-pkgver=2.2
-pkgrel=1
+pkgver=2.6
+pkgrel=2
pkgdesc="Backup and recovery manager for PostgreSQL"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.pgbarman.org"
-license=('GPL')
+license=('GPL3')
depends=('rsync' 'python2' 'python2-argh' 'python2-psycopg2' 'python2-dateutil' 'python2-argcomplete')
makedepends=('python2-distribute')
provides=('barman')
options=(!emptydirs)
-source=(http://sourceforge.net/projects/pgbarman/files/${pkgver}/barman-${pkgver}.tar.gz)
-md5sums=('1be7b8beefa2225ae77602f0a87f6938')
+source=(
+ "http://sourceforge.net/projects/pgbarman/files/${pkgver}/barman-${pkgver}.tar.gz"
+ barman.crond
+ barman.logrotate
+ passive-server.conf-template
+ ssh-server.conf-template
+ streaming-server.conf-template
+)
+md5sums=('6cf6074bf4d72718c65629d14e5f30ce'
+ '0e48345895f88b3939543c00928a199b'
+ '58c5b20b8e1272ab4ce46757f6613e0d'
+ 'b43254374978938f7d21035a3356b531'
+ 'a98247fde653192d5587fff0c2b7b5fe'
+ '6dda5a4abca99443e8956ffa719d0ce0')
package()
{
- cd "${srcdir}/barman-${pkgver}"
+ cd "${srcdir}/barman-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1 || exit 1
+
+ # install LICENSE file
+ install -Dm 0644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # install docs
+ install -Dm 0644 ChangeLog -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 0644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # install example files
+ cd doc
+ install -Dm 0644 barman.conf -t "${pkgdir}/usr/share/doc/${pkgname}/etc/"
+
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}/etc/cron.d/" \
+ "${pkgdir}/usr/share/doc/${pkgname}/etc/barman.d/" \
+ "${pkgdir}/usr/share/doc/${pkgname}/etc/logrotate.d/"
+ install -m 0644 barman.crond "${pkgdir}/usr/share/doc/${pkgname}/etc/cron.d/barman"
+ install -m 0644 barman.logrotate "${pkgdir}/usr/share/doc/${pkgname}/etc/logrotate.d/barman"
+
+ install -Dm 0644 passive-server.conf-template -t "${pkgdir}/usr/share/doc/${pkgname}/etc/barman.d/"
+ install -Dm 0644 ssh-server.conf-template -t "${pkgdir}/usr/share/doc/${pkgname}/etc/barman.d/"
+ install -Dm 0644 streaming-server.conf-template -t "${pkgdir}/usr/share/doc/${pkgname}/etc/barman.d/"
+
}