summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoosted72019-12-21 18:14:23 +0100
committerRoosted72019-12-21 18:14:23 +0100
commit26aaa0231dc86b2c21773d9a838f0a687e8db069 (patch)
tree7da5b88e3fbb0853c929fee6859f5fcbff602a33 /PKGBUILD
parent48d551d7c03c1ada7949a5db4955119a0b1ec66d (diff)
downloadaur-26aaa0231dc86b2c21773d9a838f0a687e8db069.tar.gz
New version and also install libs and headers
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a81dc9472f22..47d1092caa63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bart-git
_pkgname=bart
-pkgver=0.5.00.r16.gb197fe3
+pkgver=0.5.00.r19.g5102cb3
pkgrel=1
pkgdesc="Berkeley Advanced Reconstruction Toolbox (BART) for Computational Magnetic Resonance Imaging"
arch=('x86_64')
@@ -32,6 +32,18 @@ package() {
cd "$_pkgname"
make PREFIX="$pkgdir"/usr install
+ # Also install the libs, the viewer needs this and its not done by the Makefile atm
+ install -d "$pkgdir"/usr/lib/bart
+ install lib/* "$pkgdir"/usr/lib/bart
+
+ # Also install the headers, the viewer needs this and its not done by the Makefile atm
+ install -d "$pkgdir"/usr/include/bart
+ cd src
+ for file in $(find ./ -type f -name "*.h"); do
+ install -D ${file} "$pkgdir"/usr/include/bart/${file}
+ done
+ cd ..
+
install -d "$pkgdir"/usr/share/bart/matlab
install matlab/* "$pkgdir"/usr/share/bart/matlab
@@ -40,4 +52,4 @@ package() {
install -d "$pkgdir"/usr/share/bart/scripts
install scripts/* "$pkgdir"/usr/share/bart
-} \ No newline at end of file
+}