summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoosted72019-08-28 12:14:58 +0200
committerRoosted72019-08-28 12:14:58 +0200
commit29f974b1b734c7ee8ee7d898204f9f70ea13205b (patch)
tree7febeb5347f4f9c124f5c1e8ae87913fa498c478 /PKGBUILD
downloadaur-29f974b1b734c7ee8ee7d898204f9f70ea13205b.tar.gz
Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24a8f9860249
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Thomas Roos (Roosted7) <mail [at] thomasroos [dot] nl>
+
+pkgname=bart-git
+_pkgname=bart
+pkgver=0.5.00.r0.g5efc0a9
+pkgrel=1
+pkgdesc="Berkeley Advanced Reconstruction Toolbox (BART) for Computational Magnetic Resonance Imaging"
+arch=('x86_64')
+url="https://mrirecon.github.io/bart/"
+license=('BSD3')
+depends=('cblas' 'openblas' 'fftw' 'gcc-libs' 'lapacke' 'libpng')
+optdepends=('octave')
+source=('bart::git+https://github.com/mrirecon/bart.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+
+ # Add linking flag, seems needed for Arch. Will open PR / issue upstream
+ sed -i 's;BLAS_L := -L$(BLAS_BASE)/lib -llapacke -lblas;BLAS_L := -L$(BLAS_BASE)/lib -llapacke -lopenblas -lcblas;' Makefile
+
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make PREFIX="$pkgdir"/usr install
+} \ No newline at end of file