summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-02-19 13:21:50 -0600
committerLuis Martinez2021-02-19 13:21:50 -0600
commit481daf0ca66b7efe9a09f5d78eb2f98cb17581d1 (patch)
tree8df443603a260608b1953a57d6aba3a654dfcdf1 /PKGBUILD
downloadaur-481daf0ca66b7efe9a09f5d78eb2f98cb17581d1.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20e41e4b7bd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: lmartinez-mirror <lmartinez-mirror at noreply dot github dot com>
+pkgname=baru
+pkgver=0.2.3
+pkgrel=1
+pkgdesc='A system monitor written in Rust and C'
+arch=('x86_64')
+url='https://github.com/doums/baru'
+license=('MPL2')
+makedepends=('git' 'rust')
+optdepends=(
+ 'libnl: for wired and wireless modules'
+ 'libpulse: for sound and mic modules'
+)
+conflicts=('baru-bin')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('4812c649e98a000e134e0b149bf394b0f198845bce2036356ffb0c66921fd7220a53f866f95101212d5862ab53e2cc5e9702738f475acaea778dfd2afc00f5f2')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked
+}
+
+package() {
+ install -Dm 755 "$pkgname-$pkgver/target/release/$pkgname" -t "$pkgdir/usr/bin/"
+}
+