summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2022-07-20 21:00:20 +0200
committerHans-Nikolai Viessmann2022-07-20 21:00:20 +0200
commit06048e540f53c8f890787a12b3a5030c3b9bdcd4 (patch)
tree480c824a924827ec6cbbc4e0f589b2c4a344f0a0 /PKGBUILD
parent9c8e923522569c3d175eba2d554c66803adf9985 (diff)
downloadaur-06048e540f53c8f890787a12b3a5030c3b9bdcd4.tar.gz
bump version to 0.41.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 8 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6926ac915aab..f3a0473ed43b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,17 @@
# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
pkgname=barvinok
-pkgver=0.41.5
-pkgrel=3
+pkgver=0.41.6
+pkgrel=1
pkgdesc='A library for counting the number of integer points in (non-)parametric polytopes'
arch=('x86_64')
-url='http://barvinok.gforge.inria.fr/'
+url='https://barvinok.sourceforge.io/'
license=('GPL')
depends=('ntl' 'libisl>0.19' 'polylib-gmp')
-makedepends=('git')
-source=("git+https://repo.or.cz/barvinok.git#tag=$pkgname-$pkgver")
-sha256sums=('SKIP')
-
-prepare () {
- cd "$srcdir/$pkgname"
-
- # setup the repo
- ./get_submodules.sh
- ./autogen.sh
-}
+source=("https://barvinok.sourceforge.io/$pkgname-$pkgver.tar.xz")
+sha256sums=('1e647f847af44fced0eb554b82452f2ff7a9ab2bcb618eee3a49e44eb4f8b2dd')
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
# NTL 11 now uses pthread functions, so we need to have it link to libpthread.
./configure --prefix=/usr --enable-shared-barvinok --with-isl=system --with-polylib=system LIBS="-lpthread"
@@ -28,11 +19,11 @@ build() {
}
check() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
make check
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}