summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2021-11-02 16:34:47 +0100
committerHans-Nikolai Viessmann2021-11-02 16:34:47 +0100
commit72e48fa462d4ed11cfb6d96119deca4583b0a990 (patch)
tree8fdd5ec45f1c1a8f5b0c0f286c3b6344799358fc /PKGBUILD
parentda0273c33273faff4d18fe6bd72c3a10cb275e38 (diff)
downloadaur-72e48fa462d4ed11cfb6d96119deca4583b0a990.tar.gz
switch to git sources
the barvinok.gforge.inria.fr website looks to be dead, so instead I clone from a mirror repo hosted on repo.or.cz. The build requires that we pull in the git submodules, so this adds some time to the whole process.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 849758159eec..d1885b19844a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
pkgname='barvinok'
pkgver=0.41.5
-pkgrel=1
+pkgrel=2
pkgdesc='A library for counting the number of integer points in parametric and non-parametric polytopes'
arch=('x86_64')
url='http://barvinok.gforge.inria.fr/'
license=('GPL')
depends=('ntl' 'isl>0.19' 'polylib-gmp')
-source=("http://barvinok.gforge.inria.fr/$pkgname-$pkgver.tar.xz")
-md5sums=('c53bac2536035f624efe05664383e7cc')
+makedepends=('git')
+source=("git+https://repo.or.cz/barvinok.git#tag=$pkgname-$pkgver")
+sha256sums=('SKIP')
+
+prepare () {
+ cd "$srcdir/$pkgname"
+
+ # setup the repo
+ ./get_submodules.sh
+ ./autogen.sh
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
# NTL 11 now uses pthread functions, so we need to have it link to libpthread.
./configure --prefix=/usr --enable-shared-barvinok --with-isl=system --with-polylib=system LIBS="-lpthread"
@@ -19,11 +28,11 @@ build() {
}
check() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make check
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" install
}