summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-04-22 12:03:40 +0200
committerHans-Nikolai Viessmann2018-04-22 12:05:09 +0200
commita2a38788af8efce871804d4d29d016b3bb076507 (patch)
treed4e6440d29a25e10e34bf9d62a746107b4d43c57 /PKGBUILD
parent47811acf7b01aaa351f37caf7299efa3db3a2258 (diff)
downloadaur-a2a38788af8efce871804d4d29d016b3bb076507.tar.gz
version bump
we now no longer support ISL <= 0.17.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18afe8bf5847..c2fca4b3f73c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,29 @@
# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
pkgname='barvinok'
-pkgver=0.40
-pkgrel=2
+pkgver=0.41
+pkgrel=1
pkgdesc='A library for counting the number of integer points in parametric and non-parametric polytopes'
arch=('x86_64')
url='http://freecode.com/projects/barvinok'
license=('GPL')
-depends=('ntl' 'isl' 'polylib-gmp')
-source=("http://barvinok.gforge.inria.fr/$pkgname-$pkgver.tar.xz")
-md5sums=('a5c0b48b4e336ee652e6e517d14ea9b6')
+depends=('ntl' 'isl>0.17' 'polylib-gmp')
+source=("http://barvinok.gforge.inria.fr/$pkgname-$pkgver.tar.xz"
+ 'fix-missing-isl-include.patch')
+md5sums=('a5496a4a93f3f1f26fef07189e12314f'
+ '44a312463a5688031d26e615b8a22594')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # because we are building with system ISL, we need to correct a minor oversight, which
+ # is that a dummy library is generated to wrap around all the ISL functions - for bundled
+ # or build case, the linking is handled correctly. For system case the linking does not
+ # include the correct include path. This patch adds the missing include path.
+ patch -p0 < ../fix-missing-isl-include.patch
+
+ # rebuild autotools
+ autoconf -i
+}
build() {
cd "$srcdir/$pkgname-$pkgver"