summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUmamiAppearance2022-12-13 11:05:52 +0100
committerUmamiAppearance2022-12-13 11:05:52 +0100
commite73e4eb36222200b78c00120d152e0002f7cf32a (patch)
treeb6a85e74310d3221856a0ed6f063c2b7b6617189 /PKGBUILD
downloadaur-e73e4eb36222200b78c00120d152e0002f7cf32a.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58deee5e7afc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: UmamiAppearance <mail@umamiappearance.eu>
+
+pkgname=base-ex-cli
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="CLI for BaseEx (base conversion)"
+arch=(x86_64)
+url=https://github.com/UmamiAppearance/BaseExCLI
+license=("GPL")
+makedepends=('npm')
+noextract=("${pkgname}-${pkgver}.tgz")
+source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
+sha256sums=("60d3cc9986aa46e0348277c7140c04548b718c459305e1c29b2c57e83c4a48db")
+
+package() {
+ npm install -g --prefix "${pkgdir}/usr" --cache "${srcdir}/npm-cache" "${srcdir}/${pkgname}-${pkgver}.tgz"
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
+}
+