summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2017-01-29 04:48:17 +0100
committerBalló György2017-01-29 04:48:17 +0100
commitd3528d2e91280709e6c0e2613ac07d068ebf5a95 (patch)
tree7a895e07d5bc90da6e0ccc9789c0f7716e318310 /PKGBUILD
downloadaur-d3528d2e91280709e6c0e2613ac07d068ebf5a95.tar.gz
Add back basenji
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fb0fadafebc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Dr.Schliemann <doktor.schliemann at gmail dot com>
+# Contributor: JHeaton <jheaton at archlinux dot us>
+
+pkgname=basenji
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Volume indexing tool designed for easy and fast indexing of CD/DVD and other type of volume collections."
+arch=('any')
+url="https://launchpad.net/basenji"
+license=('GPL')
+depends=('dbus-sharp-glib' 'gnome-desktop2' 'gtk-sharp-2' 'taglib-sharp' 'udisks')
+makedepends=('gio-sharp')
+source=(https://launchpad.net/$pkgname/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz)
+md5sums=('eee951ac995359bedab23b964a8e5502')
+
+prepare() {
+ sed -i 's/dbus-sharp-1.0/dbus-sharp-2.0/
+ s/dbus-sharp-glib-1.0/dbus-sharp-glib-2.0/' configure Platform/Makefile
+}
+
+build() {
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}