summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2015-06-25 11:08:38 +0300
committerChristoph Gysin2015-06-25 11:08:38 +0300
commitcef02f482b8f99192a27543114fdd07f94afa28c (patch)
tree634be584f7c51c65bbcd708a24c339368dea0208 /PKGBUILD
downloadaur-cef02f482b8f99192a27543114fdd07f94afa28c.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4aa3c13565ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Christoph Gysin <christoph.gysin@gmail.com>
+pkgname=bashate
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A pep8 equivalent for bash scripts"
+arch=('any')
+makedepends=('setuptools')
+depends=('python')
+url="https://github.com/openstack-dev/${pkgname}"
+license=('Apache')
+source=(http://pypi.python.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('809b2eb1d7a5aea83f6ef64eefdcfef6')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py install \
+ --skip-build \
+ --optimize=1 \
+ --prefix=/usr \
+ --root=${pkgdir}
+}