summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Mullins2018-12-29 00:53:28 -0500
committerChristopher Mullins2018-12-29 00:53:28 -0500
commitb56095f8e0dc2611cba1ea685ead2fa66117d361 (patch)
treee10606e256b1d0259bdada8257a678161b146981 /PKGBUILD
downloadaur-bashcaster-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfd541fa1cf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Chris Mullins <christopher.r.mullins gmail>
+
+_pkgname=bashcaster
+pkgname=${_pkgname}-git
+pkgver=r7.5c2e454
+pkgrel=1
+pkgdesc="Bashcaster is a simple script that uses ffmpeg to record screencasts to videos or GIFs. It can record the whole screen or a window. It can optionally optimize GIFs with gifsicle.
+"
+arch=("any")
+
+url="https://github.com/alphapapa/bashcaster"
+license=("GPL3")
+
+depends=("ffmpeg" "xorg-xprop" "xorg-xwininfo" "yad")
+optdepends=("gifsicle")
+makedepends=("git")
+conflicts=("${_pkgname}")
+
+source=(
+ "${_pkgname}::git+https://github.com/alphapapa/${_pkgname}.git"
+)
+sha512sums=(
+ "SKIP"
+)
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s\n" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+
+ install -m755 -D "bashcaster.sh" "$pkgdir/usr/bin/bashcaster"
+ install -m644 -D "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}