summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcippaciong2015-07-05 11:20:25 +0200
committercippaciong2015-07-05 11:20:25 +0200
commit7b5887ef7b74bbda800d9ce386b14d362539959a (patch)
tree02c637f355bc23412638030ebc08e540dd2ffb10 /PKGBUILD
downloadaur-7b5887ef7b74bbda800d9ce386b14d362539959a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02502e97bdfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tommaso Sardelli <lacapannadelloziotom [at] gmail [dot] com>
+
+_pkgname=bashmarks
+pkgname=${_pkgname}-git
+pkgver=43
+pkgrel=2
+pkgdesc='A shell script that allows you to save and jump to commonly used directories'
+arch=('any')
+url="https://github.com/huyng/${_pkgname}"
+license=('BSD')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+install=("$pkgname.install")
+source=("git://github.com/huyng/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-list --count HEAD
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 bashmarks.sh $pkgdir/usr/share/$_pkgname/${_pkgname}.sh
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+}