summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Bruguera2020-10-07 01:14:38 +0200
committerJoan Bruguera2020-10-07 01:14:44 +0200
commit437ba59fb7dc2cae9f06b3725de400a46100163c (patch)
treed0f07a6613b0240b0271299730215d4cd2805c08 /PKGBUILD
parentb56ec57def1ae1cf29d0f844af9deecc2b084f95 (diff)
downloadaur-437ba59fb7dc2cae9f06b3725de400a46100163c.tar.gz
Follow shellcheck SC2174 recommendation.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41bcfbb35456..7f79ff005e85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='basicanalysis'
pkgdesc='Framework for automatic extraction of fundamental factors for Paraver traces (from BSC).'
pkgver='0.3.6.20180531'
-pkgrel='1'
+pkgrel='2'
arch=('any')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
@@ -19,6 +19,7 @@ package() {
find "cfgs" -type f -exec install -D -m644 "{}" "$pkgdir/usr/lib/basicanalysis/cfgs/" \;
# Create a symlink to the script in /usr/bin for ease of use
- mkdir -p -m755 "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/bin"
+ chmod 0755 "$pkgdir/usr/bin" "$pkgdir/usr"
ln -s "/usr/lib/basicanalysis/modelfactors.py" "$pkgdir/usr/bin/modelfactors.py"
} \ No newline at end of file